Compose*/Java for Eclipse

Compose*/Java for Eclipse provides an implementation of Compose* to be used with the Java programming language. This release is integrated with the Eclipse development platform.

Requirements:

  • Eclipse 3.4/Ganymede with JDT (compatible with 3.5/Galileo)
  • Java JRE 5.0 or higher

Optional:

Download the latest Compose*/Java release

Compose*/Java requires at least Java Runtime Environment 1.6 for compilation, resulting programs require at least version 1.5. But you can also use Compose*/Java on Java programs written for older versions, as long as the runtime is at least 1.5.
Starting from release v0.8.5 Eclipse 3.4 will be used as the primary plugin target. An Eclipse 3.2 and 3.3 compatible plugin is also available for the v0.8.5 release, just download the alternative file on the download page.
It is not required to install a JDK. However, if you do get an error that no Java compiler could be found you should install JDK 1.6 or later. Also make sure that javac can be called from the commandline (i.e. update the PATH environment variable).

Installation instructions
There are two methods for installation, either by downloading the zip file of the latest release. Or by using the Eclipse update URL: http://composestar.sourceforge.net/eclipse.
When you choose for downloading the zip file you need to extract the files to the Eclipse base directory.

When Compose*/Java is successfully installed you will see the Compose* logo in the about dialog of Eclipse: